Package: ClassVersionLimiter.zip
ClassVersionLimiter modifies JDK1.4 jar files, so that
it works with JBuilder5 or lower version.

Command-line:
	c:\jdkpath\bin\java.exe ClassVersionLimiter c:/jdk1.4_JB

Do not use the same "jdkpath" what you want to patch. Use JDK1.3 or
another jdk to run this program.

ClassVersionLimiter changes the version tag of all .class files 
within .jar packages. JDK1.4 classes are not version compatible with
previous jdks. This is the reason why you cannot use JBuilder5 or less
with jdk1.4 virtual machine.

1) Install JDK1.4 package to your machine or another machine
normally. (download from Sun site and run setup program)

2) Copy "c:\j2sdk1.4" folder to an another name.
Example: c:\jdk1.4_JB

3) Run ClassVersionLimiter to patch a new jdk folder.

Add a new patched jdk to your JBuilder environment.


NOTE!!!!
YOU ARE NOT ALLOWED TO DISTRIBUTE A PATCHED JDK PACKAGE TO AN 
ANOTHER MACHINE. IT IS FORBIDDED BY SUN LICENSES (no modified version
are allowed to publish or distribute in any way).

You can use it in your own JBuilder IDE at own risk. Finished 
applications run ok with the original jdk version, so there is really
not point distributing the patched one.